PEAK XOOPS - Hack Watermark for Myalbum in englishin japanese

Hack Watermark for Myalbum

  • You cannot open a new topic into this forum
  • Guests cannot post into this forum
Previous post - Next post | Parent - Children.1 .2 .3 .4 .5 .6 .7 .8 .9 .10 | Posted on 2005/8/21 5:57
edldp  Private   Posts: 7
Hello Gijoe

As i noticed you didn't really insert watermark in your update of myalbum so I decided to do it myself.

This hack is for the moment really working only on GD2 because I didn't yet manage to get ImageMagick or NetPBM work on my computer. However all the system is ready. All which is neaded is the code for the watermark to be applied. I have only included the code you inserted for the watermark but as you'll see I have included a few options for the watermark which could be interesting

Concerning what is possible with this hack.

1) You can choose in the preferences if you wish to apply watermark on the new photos. You can either use a watermark image you have already created or use a text

2) If you choose "Watermark Text" you can then insert the text of the watermark. The system will automatically create the watermark from the string you provide.

3) You can choose where you wish to apply the watermark : Bottom left, Bottom right, Top left, Top Right or Center.

Once active, the watermark will be applied to the photo even if you do a batch upload.

This hack has been done on MyAlbum 2.85 with Xoops 2.2.2 but I think it should work also on MyAlbum 2.84.

Concerning when the watermark is created from a string, you may have some problems with white photos because the text which is created has a white color.
In the next release of this hack I will give at least the possibility to choose the color of the text

For the install very easy : Overwrite your files with those in the zip file and then update your module.

And now here is the (I Hope) very wanted Hack

Edit 21/08/05: In fact the hack is now working for gd2 and Imagemagick. There is only netpbm I haven't managed to do yet
Votes:20 Average:7.00
Previous post - Next post | Parent - Children.1 .2 | Posted on 2005/8/29 8:50
Foz  Private   Posts: 6
Anyone get this to work yet? I am trying it on Xoops 2.2.3. I get the watermark options in preferences but the watermark never shows up on the pictures. I am using image magick also.

Thanks
Foz
Votes:15 Average:8.67
Previous post - Next post | Parent - Children.1 | Posted on 2005/8/30 4:02 | Last modified
GIJOE  Gunnery Sergeant   Posts: 4110
If you use myAlbum-P with ImageMagick, it is quite easy.

Use 2.85 as is.
And put a gif image as images/watermark.gif.
Votes:17 Average:8.24
Previous post - Next post | Parent - Children.1 | Posted on 2005/8/30 4:08
edldp  Private   Posts: 7
Hello Foz

I tried the hack today on Xoops 2.2.3 after having downloaded again both myalbum 2.85 and the hack and when I tested it it worked without any problems on my test server. However as I said in the first post the watermark is white right now so if you try to watermark a white image you won't see your watermark.

Try with a black image to check if there is a problem. If the watermark doesn't appear could you try to send me the apache logs if you can access them so I can see where there is an error please.
Votes:16 Average:9.38
Previous post - Next post | Parent - Children.1 | Posted on 2005/8/30 5:47
Foz  Private   Posts: 6
Hi Guys

I figured out what was going on.
I was "importing" the images. By that I mean I used the xoops image manager to create a category and upload my photos. I then used the import feature in the myablum module to import the photos from the image manager. Apparently if you do it that way the watermark doesnt seem to work.

I did however get it to work if I added the photos directly into the myalbum module without using import.

I also noticed that the watermark position has a small bug in it. 'Bottom right' places the watermark on the bottom left and 'Bottom left' places the watermark on the bottom right.

BTW thanks for all the work on this module. I never imagined someone with as little experience as me could actually have these kind of features on my website.

Thanks
foz :)
Votes:15 Average:9.33
Previous post - Next post | Parent - Children.1 | Posted on 2005/8/30 21:36
edldp  Private   Posts: 7
Hi Foz

Thanks for the bug report it is now corrected.
Concerning the import systel it is true I didn't implement the watermark feature in the hack.
I'll try as soon as I have time to see how to get it work for this using case.

Votes:17 Average:8.24
Previous post - Next post | Parent - No child | Posted on 2005/8/31 0:42
Foz  Private   Posts: 6
Hi. Thanks for the quick update :)

Found another minor bug. If you try to rotate an image using the edit feature in the myablum module 2.85, it doesnt seem to work

It seems that you can rotate it when you originally add the photo but cant afterwards when you try to edit the photo through the photo management area.

Thanks again :)
Foz
Votes:16 Average:8.13
Previous post - Next post | Parent - No child | Posted on 2005/8/31 2:10
Robertico  Private   Posts: 3
GIJOE
It doesn't work for me (version 2.85).
I created a new watermark.gif and also renamed the watermark_sample.gif to watermark_sample.gif.
(There were already images in my album)
Votes:16 Average:8.75
Previous post - Next post | Parent - Children.1 | Posted on 2005/9/14 0:03
pmhoran  Corporal From: Prince Edward Island, Canada , Canada  Posts: 52
Is this hack no longer available??

I have tried to download it but get a "404 Not Found" error.

Anyone have a copy they would like to share??? If so ... please attach the zip to an email and send to "peter at merlinean dot com"

Thanks much
Peter
Votes:15 Average:8.67
Previous post - Next post | Parent - Children.1 | Posted on 2005/9/14 4:14
Foz  Private   Posts: 6
Sent :)

Foz
Votes:17 Average:8.82
Previous post - Next post | Parent - Children.1 | Posted on 2005/9/14 6:05
pmhoran  Corporal From: Prince Edward Island, Canada , Canada  Posts: 52
Thank you so much.

Its appreciated
Peter
Votes:15 Average:9.33
Previous post - Next post | Parent - Children.1 .2 | Posted on 2005/9/15 1:02
edldp  Private   Posts: 7
Sorry for the 404 error.
This has been corrected and the link is working again
Votes:20 Average:6.50
Previous post - Next post | Parent - No child | Posted on 2005/9/15 1:29
pmhoran  Corporal From: Prince Edward Island, Canada , Canada  Posts: 52
Thanks edldp ...

Should this hack work with XOOPS 2.0.13.1 using MyAlbum 2.86a as well???

Thanks
Peter
Votes:15 Average:8.67
Previous post - Next post | Parent - Children.1 | Posted on 2005/9/17 0:40
pmhoran  Corporal From: Prince Edward Island, Canada , Canada  Posts: 52
edldp .... you can smack me upside the head if you feel like it ... but I have been trying to use the "text" version of your watermark.

As mentioned, I am using XOOPS 2.0.13.1 and MyAlbum 2.86a. And I am using GD format. The Imagemagick installation on my webhosts server must be installed wrong because it will not make thumbnails.

I have changed the color designation of $white so it uses the RGB for pink/fuscia ... and that works fine. I also found where I could increase how many letters in the "copyright text" are displayed.

However, since I DON'T know php at all, I am having difficulty getting the copyright I want to use to show up with HUGE letters. Basically ... I want a center displayed text that would cover about 450 px and letters as big and as bold as I can make them. I have gotten the letters to display a bit bigger ... but thats about it.

The photos in the album are all either 600 px or 450 px wide ... no exceptions.

Any suggestions? Or can you point me to the area I have to play around with to achieve what I need??

In your next release ... it would be nice if the user has the option of the
-size of graphic used
-size of text and color of text
-maybe even font of text used (as well as bold or italic)

Don't get me wrong here ... I think your hack is fantastic. Its the first time I have been able to get any kind of watermark to display on any pic ... and thank you very much for your efforts.

Thanks ... and thanks for any assistance you can provide.

Take care
Peter

PS ... as much as I tried yesterday and the day before ... I could not get my own watermark gif or png to show up. Today ... its working fine ... and in the full size that I made it. BINGO.
Votes:18 Average:7.22

question Re: Hack Watermark for Myalbum

msg# 1.2.1.1.1.2.1
Previous post - Next post | Parent - Children.1 | Posted on 2005/9/18 1:15
edldp  Private   Posts: 7
Hello Peter

Thanks for the kind words.

Concerning your problem I'll have a look as soon as I have some time however as I have quite a lot of things to do until thursday included I can't promise i'll have time to do it until then.
Votes:17 Average:8.24

question Re: Hack Watermark for Myalbum

msg# 1.2.1.1.1.2.1.1
Previous post - Next post | Parent - Children.1 | Posted on 2005/9/18 23:15
pmhoran  Corporal From: Prince Edward Island, Canada , Canada  Posts: 52
No rush ... I know how busy we all can get

AND ... as indicated, I finally got the graphic end of it to actually work for me ... so that is what I am using right now

I would still prefer to use the text ... if possible. Chances are ... some of the albums I will have will require different wording in the watermark. So just changing the text would be a lot easier than making up a new graphic etc.

Thanks again for any and all assistance.

Peter
Votes:15 Average:9.33

question Re: Hack Watermark for Myalbum

msg# 1.2.1.1.1.2.1.1.1
Previous post - Next post | Parent - No child | Posted on 2006/1/18 8:12
ivandr  Private   Posts: 3
Hi,

Tried downloading the file but it does not work.

Can someone please email it to me:
ivan at dretvich dot com

Thanks heaps.
And the features featured above (future suggestions) are great and we would love to not only see these features in your hack, but in myAlbum-p aswell! it would definately be a bonus.

thanks
Ivan
Votes:20 Average:8.50
Previous post - Next post | Parent - No child | Posted on 2006/1/29 20:00
Fastian  Private   Posts: 6
Hi

I am getting "404 file not found" error.
If anyone have its copy, could u please send it to me ?? Or is there any other place i can download this.

Thanks in advance
Votes:16 Average:8.75
Previous post - Next post | Parent - No child | Posted on 2007/10/9 14:57
roxanacaz  Private   Posts: 1
Please please, someone give me the watermark files! Thank you. The address is: roxana at prestariservicii . ro
Votes:15 Average:9.33
Previous post - Next post | Parent - No child | Posted on 2008/8/6 8:41
Bikegirl  Private   Posts: 1
The link for the Hack is no longer available. Could anyone supply the hack for me perhaps?

Bikegirl22 at hotmail . com

Thanks in advance
Votes:13 Average:9.23
Previous post - Next post | Parent - No child | Posted on 2008/8/6 14:50
happyman55  Private   Posts: 1
404 not found
Votes:14 Average:10.00
Previous post - Next post | Parent - Children.1 | Posted on 2009/4/14 22:29
zaza123  Private   Posts: 3
an appeal to all, I can not find the hack for the watermark for Myalbum 2.88 would need only the text mode and graphics mode using the file watermark.gif or something similar.
I am using Xoops 2.33, and GD2 graphics library.
Thank you all for your interesting and if not asking too leave my mail if you send the file to be attached
zaza AT libero . it
zaza123
Votes:15 Average:8.67
Previous post - Next post | Parent - No child | Posted on 2009/4/15 13:16
GIJOE  Gunnery Sergeant   Posts: 4110
As I wrote four years ago.

With ImageMagick, just put ROOT/modules/(dirname)/images/watermark.gif

This is just the same result like:
composite -compose plus (watermark) (photo w/o wm) (photo with wm)

I cannnot support a feature of watermark via GD2.
Votes:15 Average:9.33
Previous post - Next post | Parent - Children.1 | Posted on 2009/4/20 22:39
zaza123  Private   Posts: 3
Hello GIJOE,
thanks to your advice I managed.
Everything works!
will take advantage and ask you one last thing:
where can I set the parameters for the position of the watermark? (version 2.88 in preferences I see no parameter)
thanks anyway infinite
zaza123
Votes:12 Average:10.00
Previous post - Next post | Parent - No child | Posted on 2009/4/25 5:42
GIJOE  Gunnery Sergeant   Posts: 4110
just hack include/functions.php
This is an issue of parameter for ImageMagick binaries.
Votes:16 Average:10.00
Previous post - Next post | Parent - No child | Posted on 2009/10/15 15:23 | Last modified
jero12  Private   Posts: 1
thanks for the great help GIJOE. it works fine here
Votes:10 Average:10.00
Previous post - Next post | Parent - No child | Posted on 2011/3/29 17:06 | Last modified
barbie27  Private From: Agoura Hills, California 91301 USA  Posts: 1
By the way I don't even know how to remove water marks from images though. LOL
Nettbutikker
Lage hjemmeside
Votes:1 Average:10.00

  Advanced search


Login
Username or e-mail:

Password:

Remember Me

Lost Password?

Register now!