PEAK XOOPS - Re: Protector V3 in englishin japanese

Re: Protector V3

Target Downloads
Subject Protector 3.41
Summary ●要旨Protector は、XOOPS2ベースの各種CMSを様々な悪意ある攻撃から守るためのモジュールです。このモジュールでは、以下の攻撃を防ぎます。- DoS- 悪意あるクローラー(メール収集ボットなど)- SQL Injection- XSS (といっても、全てではありません)- システムグロ...

List posts in the topic

none Re: Protector V3

msg# 1.1
depth:
1
Previous post - Next post | Parent - Children.1 | Posted on 2007/6/24 17:23
GIJOE  先任軍曹   Posts: 4110
sippu さん、こんにちは。

Quote:

mainfile.phpのパッチ当ての件ですが、こちらの説明(Cube 2.1 Legacyへのインストール)とXCへのアップグレード公式Wiki翻訳の説明が若干異なります。
どちらが正しいのでしょうか?

確かに食い違ってますね。

最初は、READMEの通りだったのですが、_LEGACY_PREVENT_LOAD_CORE_ を定義してまで、commonプロセスを呼び出したくない状況では、Protectorが動作するのも嫌だろうな、と考え直して、Wikiの方ではそのif文の内側に移動してます。

つまり、Wikiの方が正しいってことにしてます。
(旧READMEの状態でも、間違ってはいません)

ともあれ今さっき、READMEを差し替えました。
今後は、どのドキュメントでもこの方式に統一します。

ご指摘ありがとうございました。
Votes:11 Average:8.18

Posts tree

  Advanced search


Login
Username or e-mail:

Password:

Remember Me

Lost Password?

Register now!